Help! A troublesome error!

Posted in Off Topic
Please login to contribute to the conversation.
I don't know if some of you people had this major issue occured too, but for some reason, while I'm just playing Simpsons H&R (and primarily on Lucas's Mod Launcher application) perfectly normal, even rarely an error message pops up, saying "Please insert The Simpsons Hit & Run CD 1". How strange... The disc always is in the drive running and non-ejected, and though I tried ejecting the disc, putting it back in and clicked "OK", the error message pops back again instantly and wouldn't let me resume playing the game, forcing me to close it. Annoying this is, especially when I didn't save before this occurs, and I lose all my progress. I had this error message afflicted me a few times lately, and all I can say is that it occured when I entered a vehicle, building or phonebooth menu. What causes this problem to take place? Or is it just either my laptop or the old game disc itself I had for so long?
Were you using the no-audio hack? It has happened to me be fore while i had that hack turned on. I believe it is because the hack is forcing the game to ignore several files that the game will issue you that error whne not found.
Were you using the no-audio hack? It has happened to me be fore while i had that hack turned on. I believe it is because the hack is forcing the game to ignore several files that the game will issue you that error whne not found.

Yeah I did use the No Audio hack, and that happened to me as well. But even without that hack turned on, it can still occur. Maybe it's just another cause. =/
Are you using any other hack? Also, check the disc, there maybe scratches or marks on the disc that might be stopping your pc reading it. If nothing works, uninstall and reinstall the game again. Also, make sure you save regularly as well.
Are you using any other hack? Also, check the disc, there maybe scratches or marks on the disc that might be stopping your pc reading it. If nothing works, uninstall and reinstall the game again. Also, make sure you save regularly as well.

I always play SHAR with all the eight default hacks enabled (Aspect Ratio Support, Bug Fixes, Frame Limiter, Hover Car Refraction, Lens Flare, Resizable Window, Screenshots, and Sphere Map Reflections). Sometimes I play with more other hacks and mods enabled, too. I rarely play with Developer settings turned on. Most of the time, this error does not occur, or that SHAR runs perfectly fine. And yes, my disc has some scratches, but generally it works fine. I even thought about uninstalling and reinstalling the game to see if it will work (or make a difference). Good thing I already finished the game and keeping my 100% (Save1) file in SHAR's installed folder, plus I copied this save slot to a separate folder for backup.
Were you using the no-audio hack? It has happened to me be fore while i had that hack turned on. I believe it is because the hack is forcing the game to ignore several files that the game will issue you that error whne not found.

Yeah I did use the No Audio hack, and that happened to me as well. But even without that hack turned on, it can still occur. Maybe it's just another cause. =/

Did you get it to occur outside of that hack? I'm pretty certain that's the issue, as myself & I think few other people in the discord server have experienced the same issue when the hack was on.

Edit: I think it happened to me when I paused the game or unpaused it, something like that.
Out of curiosity, does this seem to consistently happen with a certain set of mods? Or is this CD error occurring when playing the vanilla game (as in, no mods that modify the campaign to alter missions or music)?

If it seems to be happening with a certain set of mods that include custom music, that might be the issue? Prior to Lucas developing a way for us to modify RMS files in XML format, we used a really disgusting hex editing method that still had some issues. Quite often, it would corrupt the game in such a way that it would permanently keep asking the user to insert the CD, even if it was present/the user was using a cracked executable to bypass the CD check.

If that’s not the issue, I have also experienced crashes similar to the one Maz described above when leaving the game idiling at the pause menu.
I had it happen very randomly the other day in the vanilla game (No Audio disabled) just after exiting the vehicle in L1M6. Not sure if the out of vehicle cue played. Didn't happen again and was very weird though.
So if the No Audio hack is obvious... Maybe Lucas should delete it from the Mod Launcher and replace it with a new setting instead, like... No pedestrians? Besides, one can still mute the game's audio separately by lowering to 0% of all sound types in the OPTIONS menu, or by muting your audio device outside, and that certainly doesn't force the game's files to make this error commence. That's what I do too with my HP Omen laptop, by pressing the F6 key to mute and unmute instantly.
I'm not sure if I'm correct about this, but the No Audio hack allows the user to play the game without having any audio output device or drivers (which the game needs in order to run).
Could be more to that though!