Lucas mod limits my game at 50 fps no matter what

Please login to contribute to the conversation.
Hey people, I downloaded Lucas mod for Simpsons Hit and Run and stuff like resolution, skipped movies etc. work fine. However, frame limiter isn't working as intended. No matter what number I set it at it always limits the game to 50fps. The only way is to turn off frame limiter option completely but then fps skyrockets and messes up with the game. Did anyone have this problem and how did you solve it if you had.
Hey there, and welcome to the forums!

I'm not quite familiar with this particular issue as I've never heard of a user encountering this. If you don't mind me asking, what external program(s) have you used to ensure that the game's framerate is running at 50FPS as opposed to 60? Does setting the Target Framerate any higher/lower produce any other different results? You can adjust the framerate that the Frame Limiter targets by clicking the "Mod Settings..." button in the Launcher. Try seeing if something such as 30FPS produces any different results.

Many thanks!


Hello, do you have any other software such as Bandicam or Fraps running in the background?
Also, could you show me your Frame Limiter Settings as well as listing every other loaded hack/setting?

If you have any programs as listed above running, I suggest you exit them, sometimes they're the cause of that.
Hey there, and welcome to the forums!

I'm not quite familiar with this particular issue as I've never heard of a user encountering this. If you don't mind me asking, what external program(s) have you used to ensure that the game's framerate is running at 50FPS as opposed to 60? Does setting the Target Framerate any higher/lower produce any other different results? You can adjust the framerate that the Frame Limiter targets by clicking the "Mod Settings..." button in the Launcher. Try seeing if something such as 30FPS produces any different results.

Many thanks!




I am using MSI Afterburner to track my fps. I found out that if I lower my frame rate in mod settings it does in fact cap it at lower number. For example I set it at 15 because that's easy to notice and it does cap it at 15fps both with and without MSI Afterburner, so I don't think MSI Afterburner is making an issue. However, setting it to 60 or even higher at 120 fps it doesn't work, it still sits at 50fps while frame limiter is enabled.


Hello, do you have any other software such as Bandicam or Fraps running in the background?
Also, could you show me your Frame Limiter Settings as well as listing every other loaded hack/setting?

If you have any programs as listed above running, I suggest you exit them, sometimes they're the cause of that.


No, I don't have any other software other than Lucas Mod running, well except MSI Afterburner for tracking but as I've said above I don't think it's making problems.

imgur.com/a/70dv5cI

Here are the settings. I tried checking and unchecking the first two boxes but nothing gave results. Maybe something in advanced section?

imgur.com/a/VfPAs4S

Here are all the activated settings, I don't use any cheats. Worth noting that I tried disabling Antialiasing but that didn't help neither
I am unsure of why that happens, I've tried turning on MSI Afterburner as well as bandicam & strangely none of them seem to have caused any issues to me. I will forward this to the others & see if anybody has any idea what could cause it.