horrible loading for base game

Please login to contribute to the conversation.
So I downloaded the SHAR base game onto my Lenovo Ideapad flex laptop (don't have an actual desktop PC) from abandonware and after some very tedious things with directories, ISO images, downloads, installs, uninstalls and a problem executable, I got the game running... sort of!

The copyright information when you boot up the game lingers, but then the rest of the logos play out normally. Even the opening movie played normally. But the problems didn't start until I hit new game. The loading times are atrocious, I'm talking 2-7 minute load time for level 1. Bart's tutorial spiel didn't play and there was a 1-2 minute load for the tutorial mission (one time Marge's model didn't even load!) nothing except skybox was loaded when you get to the bridge to Cletus' house or the area by the kwick-e-mart.

I'd jump and end up falling forever and when I try to enter the kwick-e-mart once it loads in, I'm greeted with a black screen with the words loading. It goes on like that until it crashes. I've tried lowering the resolution, closing any programs running & even defragged my drive still with no luck. I can't exactly install a mod for a game that's not working on the only PC setup I have!

And in all this, I just wonder what exactly I'm missing or what insignificant file I overlooked or even where in the directory of the program files I was supposed to put Simpsons.exe or even if I made the right decision on a disc image reader! Any help, however condescending and patronizing is much appreciated.
Hello there, running the game without the mod launcher isn't recommended.
The mod launcher offers a lot of QOL features, settings & best of all, as it's name suggests, supports mods.
You can download it from it's official download on Mod Bakery!