Forum Mod Bakery Docs

Pure3D Editor Problem

Posted in Support
Please login to contribute to the conversation.
Hello there, it's Sans47.

I have an early 2000s PC with Windows Vista Ultimate. I recently updated from Windows XP for performance purposes. On XP, running P3D editor 4 was causing a D3D error. I upgraded to Vista hoping it would be solved, but now there's another error: I have DirectX 9 installed (otherwise the program would advice me) and i also installed SlimDX SDK 2012. The error's complete text is this:

Ok, now i have a new problem: I have Windows Vista Ultimate on an early 2000s PC. When I open Pure3D editor it shows me an error:

SlimDX.Direct3D9.Direct3D9Exception: E_FAIL: An undetermined error occurred (-2147467259)
in SlimDX.Result.Throw[T](Object dataKey, Object dataValue)
in SlimDX.Result.Record[T](Int32 hr, Boolean failed, Object dataKey, Object dataValue)
in SlimDX.Direct3D9.Device.DrawIndexedPrimitives(PrimitiveType primitiveType, Int32 baseVertexIndex, Int32 minimumVertexIndex, Int32 vertexCount, Int32 startIndex, Int32 primitiveCount)
in LucasStuff.Radical.P3DEditor4.ModelChunkViewer.RenderPrimitiveGroup(PrimitiveGroup PrimitiveGroup, ShaderChunk Shader, RenderMode RenderMode, Boolean Skin)
in LucasStuff.Radical.P3DEditor4.ModelChunkViewer.RenderPrimitiveGroups(Chunk Chunk, RenderMode RenderMode, Boolean Skin, ShaderChunk Shader)
in LucasStuff.Radical.P3DEditor4.ModelChunkViewer.PrimitiveGroupsProp.Render(Matrix ViewProj, RenderMode RenderMode, Boolean Joints, ShaderChunk Shader)
in LucasStuff.Radical.P3DEditor4.ModelChunkViewer.RenderEntities(List`1 Entities, Matrix Projection, RenderMode RenderMode, Boolean Joints)
in LucasStuff.Radical.P3DEditor4.ModelChunkViewer.Render(Int32 Width, Int32 Height, RenderMode RenderMode)
in LucasStuff.Radical.P3DEditor4.ModelChunkViewer.Process()
in LucasStuff.Radical.P3DEditor4.ModelChunkViewer.ModelChunkViewer_Paint(Object sender, PaintEventArgs e)
in System.Windows.Forms.Control.OnPaint(PaintEventArgs e)
in System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer, Boolean disposeEventArgs)
in System.Windows.Forms.Control.WmPaint(Message& m)
in System.Windows.Forms.Control.WndProc(Message& m)
in System.Windows.Forms.ScrollableControl.WndProc(Message& m)
in System.Windows.Forms.ContainerControl.WndProc(Message& m)
in System.Windows.Forms.UserControl.WndProc(Message& m)
in System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
in System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
in System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

I hope anyone could help me.


We originally handled this situation here:, I apologise for not replying, however our original conclusion still stands at this point in time.

This appears to be a physical limitation in your hardware that we may be able to workaround by viewing details about your graphics card.

Here's steps to sending us diagnostic details:

1. Download GPU-Z

2. Double-click the executable
After it's done downloading, navigate to your Downloads folder.

Accept User Account Control

3. Select "Not Now"
You can install this tool later if you'd like, but for our purposes select "Not Now".

4. Select the "Advanced" tab

5. Click the dropdown and select "DirectX 9"
It may take a second to load.

6. Right-click on the details and click "Copy All"

7. Navigate to

8. Right-click on the giant text box and select "Paste as plain text" or "Paste"

9. Scroll to the bottom and verify the paste expiration is set to "Never". Then click "Create New Paste"

10. Copy the URL by right-clicking on the url bar and clicking "Copy"

After you're done, please send us that url. You can paste it into this topic.
Sorry but it says Could Not Initialize in the DirectX 9 tab. When i install DirectX it says that it is already installed.
Did you install .NET framework 3.5? because I had this issue once and that solved it.
on Windows XP, you have to install the executable from Microsoft's website and install it, I think not too sure If Windows XP came with it. On Windows Vista i think it comes with the system not sure. but i think in Windows 7, 8, and 10 you go to Start - Control Panel - Programs and Features - Turn Windows Features on/off and check all the boxes relating to .NET Framework 3.5. Not sure if it is the same on Windows Vista but you can install it i think from Windows Update in Windows Vista and that's it! hope this helps
> Sorry but it says Could Not Initialize in the DirectX 9 tab. When i install DirectX it says that it is already installed.

I'll forward this to Lucas, however I don't know what we can do beyond this. He may know, he may not.

Thank you for that. I will try it.

@Jake Andreoli

I have sended an email to with DxDiag. txt if it can help.
I tried to do as jcilley97 said, but .Net framework 3.5 (along with 1.0,2.0,3.0 and 4) is already installed and the features don't include Net Framework.
This has nothing to do with .NET Framework 3.5, so trying to install any version of .NET Framework is useless to this situation. Windows Vista comes pre-installed with DirectX 9, so attempting to install it will not yield any better results.

At this point, our original conclusion stands. We believe this is a limitation of your hardware and there's nothing we can really do beyond this.
If you are able to get that tab to load and copy the details, we will be able to look into it more. However, at this point I'm going to have to end the support here. Sorry for the inconvenience.