Older Cheap PC Runs Simpsons Hit & Run Better Then My New Gaming Laptop?!

Please login to contribute to the conversation.
Hello! I've been getting this weird issue frame rate issue with my new gaming laptop and I'm trying to figure out on whats going on. Every time I go to a different tab and back to the game it will lag like crazy freeze for a good second and everything will come back or sometimes it will just lag forever, in order for me to have it kinda stable is disabling frame limiter and turn off aspect ratio support but the thing I find very strange is my older laptop can do it with no problem with frame limiter and aspect ratio support

Dell Inspirion 17 3721 (Old)
CPU: Intel Pentium Clocked @ 1.8 GHz (Dual Core) (Model: 2117U)
GPU: Intel HD 4000
RAM: 4GB of DDR3 (1600mhz)
HDD: WD 500GB 7200RPM

Dell Inspirion 15 7567 (New/Current)
CPU: Intel Core i5 Clocked @ 2.5 GHz can turbo to 3.5 (Quad Core) (Model: 7300HQ)
GPU: Intel HD 630 (Integrated) & Nvidia GTX 1050 (with 4GB of VRAM)
RAM: 8GB of DDR4 (2400MHz)
SSD: Samsung 850 Pro 512GB

*If you guys suggest putting the Game on the Nvidia GPU I tired and it keep putting the game on to Integrated Graphics*

**and yes the integrated graphics are some how topping out to 90% to 100% witch causing the game to lag**

please if any of you can help please tell me right away so I can fixed this horrible issue
We understand this is frustrating, however we currently have no information as to why The Simpsons: Hit & Run performs so terribly on some new hardware.

The only suggestion I have is trying to put the game on the Nvidia GPU, you can use Nvidia Control Panel to force it to use the card. Beyond that, it's something we're interested in resolving but currently have no information.

EDIT: We looked into Nvidia's Control Panel and we're unable to find the setting. It's possible this setting may show up for you. How are you changing the setting?
Here the steps I used to make the game "run" on the Nvidia GPU

1. Left Click or go to the Nvidia Control Panel
2. Go To Manage 3D settings
3. Click on Add Button
4. Put Simpsons hit and run game in there and your Lucas Mod Launcher
5. then click on the drop box and you should see "Use Global Setting (High-Performance Nvidia processor)

This is what I did to make it "Run" the game but it still runs on the Integrated GPU
Hi, I had this same issue, in which I couldn't make the game run with the dedicated GPU. What I did to solve it was enebling directx9 support. Then, V-sync wasn't working, so I enabled Borderless mode in Lucas' launcher as well, and changed to windowed mode in-game. The game was stuttering, so I had to change frame limiter to either Busy wait or Sleep and busy wait. The other two modes were very sttutery.

I hope that helps.

Edit: Actually, disabling the Frame Limiter mod and locking it with Riva Tuner made the game not stuttery too, and I perceived less input lag. So, in short, my settings are Borderless and Directx9 mods on Lucas' Mod Launcher on, an Windowed in-game setting, giving me a consistent 60 fps lock and smooth experience.
I have no idea why, but it's probably with Windows 10. It runs horrible natively on Windows 10 for some reason
same here the game runs fine on my pc at home its a gtx 1060 and i7 3770.
And on my gaming laptop its stuttering and bad fps disabling anti aliasing did a good amount of lag away but it still would lag spike. My laptop has a i5 7300hq and a 1050ti and its not using my nvidia gpu but the intel hd grahics.
i unfortunately cant disable the integrated graphics true the bios of the laptop

Edit: uhm i also found out that enabling 9dx did work ass well but like my integrated graphics is still working 30% when the game is launched but i do not have lag spikes anymore thx korai