Tutorial : How to make Simpsons Hit and Run in cel-shading using Reshade

Please login to contribute to the conversation.
01/15/2021 UPDATE : Since newer versions of Lucas Simpson Hit & Run Launcher can run the game under Directx 9, I redid the tutorial a bit and skipped the part about Dg Voodoo Software.
I also updated the UIMask template, since the older version seemed to actually do the contrary than intended with new launcher (applying cel-shading to the part that were supposed to be excluded).

Hello everyone,

I recently got to make Reshade work with the Simpsons Hit and Run, and was able to put the game in cel-shading, as you can see on the picture below.


I believe this style suits the game a lot more than "ordinary 3d", and was suggested to open a new topic about how to achieve it.

First of all, you have to make the game run under a later version of directx (Reshade apparently doesn't work with Directx 8 games), using Dg Voodoo software.

You can download it here : Dg Voodoo 2

Just extract the "exe" and the "conf" files in your executable folder, as well as the 3 files contained in the "MS" folder of the zipped file (D3D8.dll, D3Dlmm.dll, and DDraw.dll).

Now, as you launch the game, you should see a "Dg Voodoo" watermark on the corner of your screen (you can disable it later through Dg Voodoo).


Download and install ReShade : Reshade

When asked for the shaders you want to download, choose (at least) :
Technicolor 2,
Levels,
UI Mask,
SMAA.

In addition, download the "Outline" shader here : Outline shader link

Finally, download the UIMask.png here : UIMask.png
Replace the one in the "textures" folder by this one

Now, when starting the game, you should get the following screen, confirming reshade is in use :


Press the "'home" key (the one with an arrow above your "end" key), and Reshade should open.

Put the shaders in the following order and check them :
Technicolor 2 (to get better cel-shading separation and vivid colors, especially when using Voodoo which seems to "wash out" the colors a bit),
Levels (Emphasizes the contrast without messing the cel shading, in my opinion),
UIMask_Top (Tells Reshade not to apply "outline" to UI),
Outline (the actual cel shading effect),
UIMask_Bottom,
SMAA (to smooth up the picture, so that the cel shading will look less "PS2" like).

On the picture below are my presets : I think it's best not to push "outline" too far, as the picture gets all messed up. Usually, a look at the characters' eyes will tell you if you put it too far, as cel shading will make their eyes black.

Levels : leave default,
Outline : "normal-depth edge detection" + edge detection (1) + edge slope (1.600) + outline opacity (0.666)
Technicolor2 : Saturation (1.100 if using Voodoo, leave 1.000 otherwise), leave the rest to default,
UIMask : leave default,
SMAA : leave defaut.


Feel free to try others presets, or use another shaders for colors and AA.

As for me, I know I just COULDN'T play this game without celshading anymore.

Hope I could help, below is a little video of the game in motion.


Cheers !


I know this topic is old and probably nobody is going to answer me, but for the sake of god reshade is installed correctly with all files and it still doesnt appear a screen when i press home, HELP ME
Hello there, I'm sorry for this answer not being of much help, but the reshade tool isn't made by us so I don't know much about it. I've used it before, but I'm not that familiar with its errors. Does the tool even load when you start the game?
Perhaps try enabling DirectX9 in the launcher.
If that doesn't work, try taking the tutorial from beginning to the end, step by step.
I wish you good luck!
Hello there, I'm sorry for this answer not being of much help, but the reshade tool isn't made by us so I don't know much about it. I've used it before, but I'm not that familiar with its errors. Does the tool even load when you start the game?
Perhaps try enabling DirectX9 in the launcher.
If that doesn't work, try taking the tutorial from beginning to the end, step by step.
I wish you good luck!


ayo i didnt enable dx9 i hope it works, thx man
You're welcome! I hope it works too.
Hello there, I'm sorry for this answer not being of much help, but the reshade tool isn't made by us so I don't know much about it. I've used it before, but I'm not that familiar with its errors. Does the tool even load when you start the game?
Perhaps try enabling DirectX9 in the launcher.
If that doesn't work, try taking the tutorial from beginning to the end, step by step.
I wish you good luck!


YAAAAAASSSSSSSSSS IT WORKED THANK U SO MUCHHHH
Hello there, I'm sorry for this answer not being of much help, but the reshade tool isn't made by us so I don't know much about it. I've used it before, but I'm not that familiar with its errors. Does the tool even load when you start the game?
Perhaps try enabling DirectX9 in the launcher.
If that doesn't work, try taking the tutorial from beginning to the end, step by step.
I wish you good luck!


YAAAAAASSSSSSSSSS IT WORKED THANK U SO MUCHHHH

You're welcome!
I'm still in shock that so many fans are working on a 2003 game, great respect to the people who create shaders and mods
*SOLVED* I can't seem to get the UI masks to work at all, I have shared a link to this post and your UI mask in hopes that someone will assist me I hope you're alright with that, I respect the effort you have put in I give you full credit. forum.donutteam.com/forum/topic/5122 There's the link to my post on the Donut Team forums. *SOLVED*
I made the white parts transparent in photoshop so I solved my issue.
I have a really strange problem where there seems to be some kind of plane, where the hud is, covering the game that ReShade picks up as the depth buffer.


In the main menu when I select an option and the camera pans, it actually detects the correct buffer, presumably because the plane temporarily disappears.


However, as soon as the animation is done ReShade goes back to detecting this weird plane as the depth buffer.


I can't find any solution to this anywhere on the internet and I'm guessing nobody else here has run into this problem. It prevents me from using and kind of depth related shaders, including this cel-shading one in the game.

EDIT: I figured out how to fix this. You have to download the version of ReShade with full add-on support and then checkmark "Copy depth buffer before clear operations" in the add-ons tab.